Is there a NuGet package for GraphSharp?

Mar 4, 2012 at 6:01 PM
It would make it much easier to get started with.
Jun 15, 2012 at 8:20 AM

Yes, please submit a NuGet package.

Jul 22, 2012 at 10:12 AM

+1

Sep 17, 2012 at 4:07 PM

As no one else did it - we did it:

http://nuget.org/packages/GraphSharp

Sep 18, 2012 at 7:33 AM
Edited Sep 18, 2012 at 7:34 AM

Cool! Thanks!

But why Dependencies:
QuickGraph (= 3.3.51106.0) not just >= 3.3.51106.0? The latest QuickGraph is 3.6.61119.7. And they work fine together, I tested.

Sep 18, 2012 at 7:45 AM

The latest QuickGraph NuGet Package installs only for .NET 4 - but I need 3.5 (for some special reasons).

Sep 18, 2012 at 10:18 AM

Still don't understand why have you set a strict dependency instead of loose? Can't you set just unspecified version of QG by analogy with WPFtk?

Sep 18, 2012 at 10:31 AM

I've tried that and NuGet selected the highest Version. Then I get an error, that my Project can't reference QuickGraph in that Version because the Target Framework does not match.

But I'm always open for improvements and tipps on how to make it better. If there is a way to reference Graph# with a 3.5 Project AND letting the QuickGraph reference unspecified, I'll update the package.

Sep 20, 2012 at 1:53 AM

+1 for this.

I got an same error with higher QuickGraph version in Nuget.

Sep 20, 2012 at 6:42 PM

I have an idea: can't you produce two versions - one bound to currently used version of QG, and another - to the latest? What do you think?

And thank you anyway! That's great you found a time for all this stuff.